幸运彩票 分数 15作者 陈越单位 浙江大学

Source

彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。

输入格式:

输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。

输出格式:

对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!;否则输出 Wish you good luck.

输入样例:

2
233008
123456

输出样例:

You are lucky!
Wish you good luck.

AC代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;


int main() {
	int n;
	cin >> n;
	string s;
	getchar();
	for (int i = 0; i < n; i++) {
		getline(cin, s);
		int a = 0, b = 0;
		for (int i = 0; i < 3; i++)a += (s[i] - '0');
		for (int i = 3; i < 6; i++)b += (s[i] - '0');
		if (a == b)cout << "You are lucky!" << endl;
		else cout << "Wish you good luck." << endl;
	}
	
	return 0;
}